Video PortalAudio PortalGames PortalArt PortalBulletin Board SystemSearch
In Those Dark Shadows Collab

AUTHOR INFORMATION

RealFaction

Author
RealFaction





Following

ngutils.initFollowButton"#ffr_58adc7fd8c152_2", "19d09%Od55ddb47a5a8%349dOfb49c74f15%Pc17c1r80%%542394%7%9%17b%255bs488b782eO01fer9746rs%889824%%sb%3%acfdb5df3dar5Pd762%25rP1cdb8d3rf4bc067a03d264e56e78059aa7802ab75%s%4d7P%%O%rr89743998318696578", "ff-g-gC4-mu7N";
AUTHOR COMMENTS

Ok so my friend JaylinSaphire (Josh) sent me a song which was the first half of this song, then I built on it. He's the one that started off "Frozen Sun" from my new album. His friend (who we can't contact) Nick did the percussion, so I just kept going with the pattern he made. I added a synth, tryed adding more bass, and made the second half of this. I think me and Josh have some real chemistry, so enjoy! :) Go to my post and check out my album!

THE PEOPLE HAVE SPOKEN

sweetnesswqsweetnesswq

Rated 3.5 / 5 stars ::

its ok

getting there :D


PhyrnnaPhyrnna

Rated 3.5 / 5 stars ::

Mmm. not bad.

The song itself isn't bad. But there are quite the number of mixing issues at hand here.

At 0:20 when the first synth comes in, it's sharp around the edges and it clips. I think what you need to do is EQ out some of the higher frequencies. That or dampen the high frequencies in the reverb and/or change the high cut. As for the volume... either try lowering it or soft clipping it.

The same goes for the whistly sound that enters at 0:40. You need to put a low pass on the EQ for the high frequencies. The level is probably fine... but maybe soft clip it for good measure.

The sound at 0:55 is alright.. although for my personal taste it needs to be smoothen out. It's a bare synth as is, and needs some effects (flanger, chorus, etc...) to make it smoother. This synth laid on top of the last two just really makes the song clip.

At 1:36 where the two synths play the melody in sync... it's a bit harsh. Mainly because of the bad mixing and mastering issues. I think you need to fix the synths first and then see if that part still works.

At 1:49 where all the other sounds break off... that's not a good outro. It doesn't really work well and leaves the listener dangling. The increase in reverb at the end also is bad. At least for the synth as is. It's too harsh to do that, since increasing the reverb only increases the pain on the ears. Probably smoothen out the synth first. Then for the reverb effect, use either an automation to increase the wet level near the end, or use an automation to increase the decay time. Either works, depending on what sound you're going for.

Needs a bunch more work, but gots potential.

~Phyrnna ^_^


Created by The New Age Soldier